package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<index>\d)\nEA\n\s(?<quantity>[0-9\.]+)\s(?<partNumber>[0-9A-Z-]+)\s(?<unknonw1>[0-9\.]+)\s(?<unknonw2>[0-9\.]+)\n(?<partName>[A-Z\s]+)\nDrawing\:\s(?<drawing>[A-Z]+)\nDue\:\s(?<date>[0-9]+\/[0-9]+\/[0-9]+)\sRequester\:\s(?<requester>[A-Z]+)\nOrder\:\s(?<order>[0-9A-Z-]+)\sSeq\sNo\:\s(?<sequence>[0-9]+)$`)
var str = `1
EA
2.00 2814-212-D003 0.00 0.00
LONG JACK PAD
Drawing: OPT
Due: 05/19/2023 Requester: NMB
Order: 2843HR-213-703 Seq No: 9002
2
EA
2.00 2814-212-D003 0.00 0.00
LONG JACK PAD
Drawing: OPT
Due: 05/19/2023 Requester: NMB
Order: 2843HR-214-703 Seq No: 9002
3
EA
2.00 2814-212-D004 0.00 0.00
SHORT JACK PAD
Drawing: OPT
Due: 05/19/2023 Requester: NMB
Order: 2843HR-213-703 Seq No: 9003
4
EA
2.00 2814-212-D004 0.00 0.00
SHORT JACK PAD
Drawing: OPT
Due: 05/19/2023 Requester: NMB
Order: 2843HR-214-703 Seq No: 9003`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}