const regex = /^(?<index>\d)\nEA\n\s(?<quantity>[0-9\.]+)\s(?<partNumber>[0-9A-Z-]+)\s(?<unknonw1>[0-9\.]+)\s(?<unknonw2>[0-9\.]+)\n(?<partName>[A-Z\s]+)\nDrawing\:\s(?<drawing>[A-Z]+)\nDue\:\s(?<date>[0-9]+\/[0-9]+\/[0-9]+)\sRequester\:\s(?<requester>[A-Z]+)\nOrder\:\s(?<order>[0-9A-Z-]+)\sSeq\sNo\:\s(?<sequence>[0-9]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<index>\\d)\\nEA\\n\\s(?<quantity>[0-9\\.]+)\\s(?<partNumber>[0-9A-Z-]+)\\s(?<unknonw1>[0-9\\.]+)\\s(?<unknonw2>[0-9\\.]+)\\n(?<partName>[A-Z\\s]+)\\nDrawing\\:\\s(?<drawing>[A-Z]+)\\nDue\\:\\s(?<date>[0-9]+\\\/[0-9]+\\\/[0-9]+)\\sRequester\\:\\s(?<requester>[A-Z]+)\\nOrder\\:\\s(?<order>[0-9A-Z-]+)\\sSeq\\sNo\\:\\s(?<sequence>[0-9]+)$', 'gm')
const str = `1
EA
2.00 2814-212-D003 0.00 0.00
LONG JACK PAD
Drawing: OPT
Due: 05/19/2023 Requester: NMB
Order: 2843HR-213-703 Seq No: 9002
2
EA
2.00 2814-212-D003 0.00 0.00
LONG JACK PAD
Drawing: OPT
Due: 05/19/2023 Requester: NMB
Order: 2843HR-214-703 Seq No: 9002
3
EA
2.00 2814-212-D004 0.00 0.00
SHORT JACK PAD
Drawing: OPT
Due: 05/19/2023 Requester: NMB
Order: 2843HR-213-703 Seq No: 9003
4
EA
2.00 2814-212-D004 0.00 0.00
SHORT JACK PAD
Drawing: OPT
Due: 05/19/2023 Requester: NMB
Order: 2843HR-214-703 Seq No: 9003`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}