import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<index>\\d)\\nEA\\n\\s(?<quantity>[0-9\\.]+)\\s(?<partNumber>[0-9A-Z-]+)\\s(?<unknonw1>[0-9\\.]+)\\s(?<unknonw2>[0-9\\.]+)\\n(?<partName>[A-Z\\s]+)\\nDrawing\\:\\s(?<drawing>[A-Z]+)\\nDue\\:\\s(?<date>[0-9]+\\/[0-9]+\\/[0-9]+)\\sRequester\\:\\s(?<requester>[A-Z]+)\\nOrder\\:\\s(?<order>[0-9A-Z-]+)\\sSeq\\sNo\\:\\s(?<sequence>[0-9]+)$";
final String string = "1\n"
+ "EA\n"
+ " 2.00 2814-212-D003 0.00 0.00\n"
+ "LONG JACK PAD\n"
+ "Drawing: OPT\n"
+ "Due: 05/19/2023 Requester: NMB\n"
+ "Order: 2843HR-213-703 Seq No: 9002\n"
+ "2\n"
+ "EA\n"
+ " 2.00 2814-212-D003 0.00 0.00\n"
+ "LONG JACK PAD\n"
+ "Drawing: OPT\n"
+ "Due: 05/19/2023 Requester: NMB\n"
+ "Order: 2843HR-214-703 Seq No: 9002\n"
+ "3\n"
+ "EA\n"
+ " 2.00 2814-212-D004 0.00 0.00\n"
+ "SHORT JACK PAD\n"
+ "Drawing: OPT\n"
+ "Due: 05/19/2023 Requester: NMB\n"
+ "Order: 2843HR-213-703 Seq No: 9003\n"
+ "4\n"
+ "EA\n"
+ " 2.00 2814-212-D004 0.00 0.00\n"
+ "SHORT JACK PAD\n"
+ "Drawing: OPT\n"
+ "Due: 05/19/2023 Requester: NMB\n"
+ "Order: 2843HR-214-703 Seq No: 9003";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}