#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[&.a-zA-Z>:+~,\h]+$"
Local $sString = "// YES:" & @CRLF & _
"class" & @CRLF & _
"somethingSomething" & @CRLF & _
"&Class" & @CRLF & _
"&.class" & @CRLF & _
"input > input" & @CRLF & _
"& > &" & @CRLF & _
"~ class" & @CRLF & _
"> div" & @CRLF & _
"a, c" & @CRLF & _
"&.disabled:disabled:hover" & @CRLF & _
"" & @CRLF & _
"// NO:" & @CRLF & _
"class-class" & @CRLF & _
"class--class" & @CRLF & _
"&-class" & @CRLF & _
"&--class" & @CRLF & _
"&__class"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")