package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[&.a-zA-Z>:+~,\h]+$`)
var str = `// YES:
class
somethingSomething
&Class
&.class
input > input
& > &
~ class
> div
a, c
&.disabled:disabled:hover
// NO:
class-class
class--class
&-class
&--class
&__class`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}