import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[&.a-zA-Z>:+~,\\h]+$";
final String string = "// YES:\n"
+ "class\n"
+ "somethingSomething\n"
+ "&Class\n"
+ "&.class\n"
+ "input > input\n"
+ "& > &\n"
+ "~ class\n"
+ "> div\n"
+ "a, c\n"
+ "&.disabled:disabled:hover\n\n"
+ "// NO:\n"
+ "class-class\n"
+ "class--class\n"
+ "&-class\n"
+ "&--class\n"
+ "&__class";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}