#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\.[^.\n]*Math[^.\n]*\..*$"
Local $sString = "Grade 8.Maths Test.Maths" & @CRLF & _
"Grade 8.Maths Test.Maths" & @CRLF & _
"Grade 6.Maths Formative Assessment.NA" & @CRLF & _
"Grade 3.Multiplication new.Mathematics" & @CRLF & _
"Grade 3.Demo Adaptive Module.Mathematics" & @CRLF & _
"Grade 4.Poetry.English" & @CRLF & _
"Maths 4.Primary.Maths" & @CRLF & _
"Maths 5.Primary.Concepts" & @CRLF & _
"Grade 8.English Math Word.English"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")