const regex = new RegExp('^.*\\.[^.\\n]*Math[^.\\n]*\\..*$', 'gm')
const str = `Grade 8.Maths Test.Maths
Grade 8.Maths Test.Maths
Grade 6.Maths Formative Assessment.NA
Grade 3.Multiplication new.Mathematics
Grade 3.Demo Adaptive Module.Mathematics
Grade 4.Poetry.English
Maths 4.Primary.Maths
Maths 5.Primary.Concepts
Grade 8.English Math Word.English`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}