import re
regex = re.compile(r"^.*\.[^.\n]*Math[^.\n]*\..*$", flags=re.MULTILINE)
test_str = ("Grade 8.Maths Test.Maths\n"
"Grade 8.Maths Test.Maths\n"
"Grade 6.Maths Formative Assessment.NA\n"
"Grade 3.Multiplication new.Mathematics\n"
"Grade 3.Demo Adaptive Module.Mathematics\n"
"Grade 4.Poetry.English\n"
"Maths 4.Primary.Maths\n"
"Maths 5.Primary.Concepts\n"
"Grade 8.English Math Word.English")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")