using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\.[^.\n]*Math[^.\n]*\..*$";
string input = @"Grade 8.Maths Test.Maths
Grade 8.Maths Test.Maths
Grade 6.Maths Formative Assessment.NA
Grade 3.Multiplication new.Mathematics
Grade 3.Demo Adaptive Module.Mathematics
Grade 4.Poetry.English
Maths 4.Primary.Maths
Maths 5.Primary.Concepts
Grade 8.English Math Word.English";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}