#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,9}\.\d{1,2}$"
Local $sString = "0.50" & @CRLF & _
"" & @CRLF & _
"1.00" & @CRLF & _
"1.000" & @CRLF & _
"" & @CRLF & _
"99999.99" & @CRLF & _
"" & @CRLF & _
"999999999.00" & @CRLF & _
"9999999999.00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")