re = /^\d{1,9}\.\d{1,2}$/m
str = '0.50
1.00
1.000
99999.99
999999999.00
9999999999.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end