const regex = /^\d{1,9}\.\d{1,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,9}\\.\\d{1,2}$', 'gm')
const str = `0.50
1.00
1.000
99999.99
999999999.00
9999999999.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}