$re = '/^\d{1,9}\.\d{1,2}$/m';
$str = '0.50
1.00
1.000
99999.99
999999999.00
9999999999.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);