using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\d+-]*([+-]?)\s*+(\d++(?:\.\d+)?)|\G[^\d+-]*(?:([+-])\s*+((?2))|((?2)))|[+-]++|[^+-]++";
string substitution = @"${2:+$1$2}${3:+$3$4}${5:++$5}";
string input = @" Lorem ipsum dolor sit amet.
Nullam 000 ut finibus 111 lectus.
Praesent 222 eu 333 sem lorem.
Fusce elementum 444 gravida 555 luctus.
Sed non ""accumsan"" - 777 lorem!
1. Vivamus at mauris mi.[1]
2. Duis ac faucibus elit.[2][3]
3. Sed sed 'tempor' diam.[4,5]
Vivamus 2024-12-21 tincidunt tristique dolor.
""Morbi vel blandit augue?""
Morbi eu tortor 25.25 ligula.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}