# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\d+-]*([+-]?)\s*+(\d++(?:\.\d+)?)|\G[^\d+-]*(?:([+-])\s*+((?2))|((?2)))|[+-]++|[^+-]++"
test_str = (" Lorem ipsum dolor sit amet.\n"
" Nullam 000 ut finibus 111 lectus.\n"
" Praesent 222 eu 333 sem lorem.\n"
" Fusce elementum 444 gravida 555 luctus.\n"
" Sed non \"accumsan\" - 777 lorem!\n"
" 1. Vivamus at mauris mi.[1]\n"
" 2. Duis ac faucibus elit.[2][3]\n"
" 3. Sed sed 'tempor' diam.[4,5]\n"
" Vivamus 2024-12-21 tincidunt tristique dolor.\n"
" \"Morbi vel blandit augue?\"\n"
" Morbi eu tortor 25.25 ligula.")
subst = "${2:+$1$2}${3:+$3$4}${5:++$5}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.