import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\d+-]*([+-]?)\\s*+(\\d++(?:\\.\\d+)?)|\\G[^\\d+-]*(?:([+-])\\s*+((?2))|((?2)))|[+-]++|[^+-]++";
final String string = " Lorem ipsum dolor sit amet.\n"
+ " Nullam 000 ut finibus 111 lectus.\n"
+ " Praesent 222 eu 333 sem lorem.\n"
+ " Fusce elementum 444 gravida 555 luctus.\n"
+ " Sed non \"accumsan\" - 777 lorem!\n"
+ " 1. Vivamus at mauris mi.[1]\n"
+ " 2. Duis ac faucibus elit.[2][3]\n"
+ " 3. Sed sed 'tempor' diam.[4,5]\n"
+ " Vivamus 2024-12-21 tincidunt tristique dolor.\n"
+ " \"Morbi vel blandit augue?\"\n"
+ " Morbi eu tortor 25.25 ligula.";
final String subst = "${2:+$1$2}${3:+$3$4}${5:++$5}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}