#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b(.*?):(|\s)(.*?);"
Local $sString = "div {" & @CRLF & _
" color: red;" & @CRLF & _
" background-color: red;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"<div style='color: red; background-color: black'>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"\b(.*?):(|\s)(.*?);"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")