import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(.*?):(|\\s)(.*?);";
final String string = "div {\n"
+ " color: red;\n"
+ " background-color: red;\n"
+ "}\n\n"
+ "<div style='color: red; background-color: black'>\n\n\n\n"
+ "\\b(.*?):(|\\s)(.*?);";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}