package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(.*?):(|\s)(.*?);`)
var str = `div {
color: red;
background-color: red;
}
<div style='color: red; background-color: black'>
\b(.*?):(|\s)(.*?);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}