using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b
(?# capture each letter up to N of them)
(\w)
(?:(\w)
(?:(\w)
(?:(\w)
(?:(\w)
(?:(\w)
)?
)?
)?
)?
)?
\b
(?# stuff between the first and second words)
\s+
\b
(?# Assert that the same letters appear if we found one before)
(?(1)(?=\w*\1))
(?(2)(?=\w*\2))
(?(3)(?=\w*\3))
(?(4)(?=\w*\4))
(?(5)(?=\w*\5))
(?(6)(?=\w*\6))
(?# assert that the length matches)
(?(6)(\w{6})
|(?(5)(\w{5})
|(?(4)(\w{4})
|(?(3)(\w{3})
|(?(2)(\w{2})
)
)
)
)
)
\b
";
string input = @"
fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo now we go with smart trams maps amps because declamations anecdotalism reoccupation cornucopiate
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}