import Foundation
let pattern = ##"""
\b
(?# capture each letter up to N of them)
(\w)
(?:(\w)
(?:(\w)
(?:(\w)
(?:(\w)
(?:(\w)
)?
)?
)?
)?
)?
\b
(?# stuff between the first and second words)
\s+
\b
(?# Assert that the same letters appear if we found one before)
(?(1)(?=\w*\1))
(?(2)(?=\w*\2))
(?(3)(?=\w*\3))
(?(4)(?=\w*\4))
(?(5)(?=\w*\5))
(?(6)(?=\w*\6))
(?# assert that the length matches)
(?(6)(\w{6})
|(?(5)(\w{5})
|(?(4)(\w{4})
|(?(3)(\w{3})
|(?(2)(\w{2})
)
)
)
)
)
\b
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo now we go with smart trams maps amps because declamations anecdotalism reoccupation cornucopiate
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)