// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)\b
(?# capture each letter up to N of them)
(\w)
(?:(\w)
(?:(\w)
(?:(\w)
(?:(\w)
(?:(\w)
)?
)?
)?
)?
)?
\b
(?# stuff between the first and second words)
\s+
\b
(?# Assert that the same letters appear if we found one before)
(?(1)(?=\w*\1))
(?(2)(?=\w*\2))
(?(3)(?=\w*\3))
(?(4)(?=\w*\4))
(?(5)(?=\w*\5))
(?(6)(?=\w*\6))
(?# assert that the length matches)
(?(6)(\w{6})
|(?(5)(\w{5})
|(?(4)(\w{4})
|(?(3)(\w{3})
|(?(2)(\w{2})
)
)
)
)
)
\b
").unwrap();
let string = "
fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo now we go with smart trams maps amps because declamations anecdotalism reoccupation cornucopiate
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}