import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\n"
+ "(?# capture each letter up to N of them)\n"
+ "(\\w)\n"
+ "(?:(\\w)\n"
+ "(?:(\\w)\n"
+ "(?:(\\w)\n"
+ "(?:(\\w)\n"
+ "(?:(\\w)\n"
+ ")?\n"
+ ")?\n"
+ ")?\n"
+ ")?\n"
+ ")?\n"
+ "\\b\n\n"
+ "(?# stuff between the first and second words)\n"
+ "\\s+\n\n"
+ "\\b\n"
+ "(?# Assert that the same letters appear if we found one before)\n"
+ "(?(1)(?=\\w*\\1))\n"
+ "(?(2)(?=\\w*\\2))\n"
+ "(?(3)(?=\\w*\\3))\n"
+ "(?(4)(?=\\w*\\4))\n"
+ "(?(5)(?=\\w*\\5))\n"
+ "(?(6)(?=\\w*\\6))\n\n"
+ "(?# assert that the length matches)\n"
+ "(?(6)(\\w{6})\n"
+ "|(?(5)(\\w{5})\n"
+ "|(?(4)(\\w{4})\n"
+ "|(?(3)(\\w{3})\n"
+ "|(?(2)(\\w{2})\n"
+ ")\n"
+ ")\n"
+ ")\n"
+ ")\n"
+ ")\n"
+ "\\b\n";
final String string = "\n\n"
+ "fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo now we go with smart trams maps amps because declamations anecdotalism reoccupation cornucopiate\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}