# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<a(?:(?!<\\/a>).)*<\\/(?!a>)[^>]+>//gm;t' <<< "1. cipe at <a href=\"http://www.example.com/2015/05/choco-taco.html</div>
2 . <a href=\"http://www.example.com/choco-taco.html></a>
3 . <div><a href=\"http://www.example.com/choco-taco.html></a></div>"