import Foundation
let pattern = #"<a(?:(?!<\/a>).)*<\/(?!a>)[^>]+>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. cipe at <a href="http://www.example.com/2015/05/choco-taco.html</div>
2 . <a href="http://www.example.com/choco-taco.html></a>
3 . <div><a href="http://www.example.com/choco-taco.html></a></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)