import re
regex = re.compile(r"<a(?:(?!<\/a>).)*<\/(?!a>)[^>]+>", flags=re.MULTILINE)
test_str = ("1. cipe at <a href=\"http://www.example.com/2015/05/choco-taco.html</div>\n\n"
"2 . <a href=\"http://www.example.com/choco-taco.html></a>\n\n"
"3 . <div><a href=\"http://www.example.com/choco-taco.html></a></div>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)