$re = '/<a(?:(?!<\/a>).)*<\/(?!a>)[^>]+>/m';
$str = '1. cipe at <a href="http://www.example.com/2015/05/choco-taco.html</div>
2 . <a href="http://www.example.com/choco-taco.html></a>
3 . <div><a href="http://www.example.com/choco-taco.html></a></div>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;