#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}$"
Local $sString = "# Regex to validate IP Address" & @CRLF & _
"# Sample IP addresses" & @CRLF & _
"192.168.25.154" & @CRLF & _
"8.8.8.8" & @CRLF & _
"7.54.69.45" & @CRLF & _
"8.8.8" & @CRLF & _
"192.256.0.15"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")