import re
regex = re.compile(r"^((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}$", flags=re.MULTILINE)
test_str = ("# Regex to validate IP Address\n"
"# Sample IP addresses\n"
"192.168.25.154\n"
"8.8.8.8\n"
"7.54.69.45\n"
"8.8.8\n"
"192.256.0.15")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")