$re = '/^((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}$/m';
$str = '# Regex to validate IP Address
# Sample IP addresses
192.168.25.154
8.8.8.8
7.54.69.45
8.8.8
192.256.0.15';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);