use strict;
my $str = '# Regex to validate IP Address
# Sample IP addresses
192.168.25.154
8.8.8.8
7.54.69.45
8.8.8
192.256.0.15';
my $regex = qr/^((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}