using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(wert|wert2)""\s*:\s*{.*""WERTNAME2""\s*:\s*""?([^,""]+)";
string input = @"""wert"":{""WERTNAME1"":WWWW,""WERTNAME2"":XXXX, ""WERTNAME3"":YYYY, ""WERTNAME4"":ZZZZ}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}