$re = '/"(wert|wert2)"\s*:\s*{.*"WERTNAME2"\s*:\s*"?([^,"]+)/mis';
$str = '"wert":{"WERTNAME1":WWWW,"WERTNAME2":XXXX, "WERTNAME3":YYYY, "WERTNAME4":ZZZZ}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);