import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(wert|wert2)\"\\s*:\\s*\\{.*\"WERTNAME2\"\\s*:\\s*\"?([^,\"]+)";
final String string = "\"wert\":{\"WERTNAME1\":WWWW,\"WERTNAME2\":XXXX, \"WERTNAME3\":YYYY, \"WERTNAME4\":ZZZZ}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}