package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mis)"(wert|wert2)"\s*:\s*{.*"WERTNAME2"\s*:\s*"?([^,"]+)`)
var str = `"wert":{"WERTNAME1":WWWW,"WERTNAME2":XXXX, "WERTNAME3":YYYY, "WERTNAME4":ZZZZ}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}