#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<text>\w.*)(?:[\d]{2,},[\d]{2}\s+|\s+)(?<fromdate>\d{1,}\s\w{3})\s-\s(?<todate>\d{1,}\s\w{3})\s(?<year>\d{4})\s(?<num1>\d{2,},\d{2})$"
Local $sString = "My super data plan 10gb mobile 99,00 1 jul - 31 jul 2020 99,00" & @CRLF & _
"My super data plan 10gb mobile 1 jul - 31 jul 2020 99,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")