import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<text>\\w.*)(?:[\\d]{2,},[\\d]{2}\\s+|\\s+)(?<fromdate>\\d{1,}\\s\\w{3})\\s-\\s(?<todate>\\d{1,}\\s\\w{3})\\s(?<year>\\d{4})\\s(?<num1>\\d{2,},\\d{2})$";
final String string = "My super data plan 10gb mobile 99,00 1 jul - 31 jul 2020 99,00\n"
+ "My super data plan 10gb mobile 1 jul - 31 jul 2020 99,00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}