const regex = /^(?<text>\w.*)(?:[\d]{2,},[\d]{2}\s+|\s+)(?<fromdate>\d{1,}\s\w{3})\s-\s(?<todate>\d{1,}\s\w{3})\s(?<year>\d{4})\s(?<num1>\d{2,},\d{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<text>\\w.*)(?:[\\d]{2,},[\\d]{2}\\s+|\\s+)(?<fromdate>\\d{1,}\\s\\w{3})\\s-\\s(?<todate>\\d{1,}\\s\\w{3})\\s(?<year>\\d{4})\\s(?<num1>\\d{2,},\\d{2})$', 'gm')
const str = `My super data plan 10gb mobile 99,00 1 jul - 31 jul 2020 99,00
My super data plan 10gb mobile 1 jul - 31 jul 2020 99,00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}