re = /^(?<text>\w.*)(?:[\d]{2,},[\d]{2}\s+|\s+)(?<fromdate>\d{1,}\s\w{3})\s-\s(?<todate>\d{1,}\s\w{3})\s(?<year>\d{4})\s(?<num1>\d{2,},\d{2})$/m
str = 'My super data plan 10gb mobile 99,00 1 jul - 31 jul 2020 99,00
My super data plan 10gb mobile 1 jul - 31 jul 2020 99,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end