const regex = /(?i)policy\s+number\s+([A-Z]{4}\d+)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)policy\\s+number\\s+([A-Z]{4}\\d+)\\b', 'gm')
const str = ` Policy Number ABCD000012345 other text follows in same line....`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}