$re = '/(?i)policy\s+number\s+([A-Z]{4}\d+)\b/m';
$str = ' Policy Number ABCD000012345 other text follows in same line....';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);