$re = '/^(?:(?:0x|\$)[0-9A-Fa-f]+|[0-9A-Fa-f]+h)$/m';
$str = '0xA
0xa
0x101
0x747
101h
$747
A
0xa$
0x
$0xA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);