re = /^(?:(?:0x|\$)[0-9A-Fa-f]+|[0-9A-Fa-f]+h)$/m
str = '0xA
0xa
0x101
0x747
101h
$747
A
0xa$
0x
$0xA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end