import re
regex = re.compile(r"^(?:(?:0x|\$)[0-9A-Fa-f]+|[0-9A-Fa-f]+h)$", flags=re.MULTILINE)
test_str = ("0xA\n"
"0xa\n"
"0x101\n"
"0x747\n"
"101h\n"
"$747\n\n"
"A\n"
"0xa$\n"
"0x\n"
"$0xA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")