// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:0x|\$)[0-9A-Fa-f]+|[0-9A-Fa-f]+h)$").unwrap();
let string = "0xA
0xa
0x101
0x747
101h
$747
A
0xa$
0x
$0xA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}