import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Zahlbetrag.*?\\K\\d+,\\d{2}(?=\\s*CHF)";
final String string = "Zwischentotal 0,00 13,24 906,79 CHF\n"
+ "Zahlbetrag 0,00 13,25 906,80 CHF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}