re = /Zahlbetrag.*?\K\d+,\d{2}(?=\s*CHF)/m
str = 'Zwischentotal 0,00 13,24 906,79 CHF
Zahlbetrag 0,00 13,25 906,80 CHF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end