$re = '/Zahlbetrag.*?\K\d+,\d{2}(?=\s*CHF)/m';
$str = 'Zwischentotal 0,00 13,24 906,79 CHF
Zahlbetrag 0,00 13,25 906,80 CHF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);