const regex = /Zahlbetrag.*?\K\d+,\d{2}(?=\s*CHF)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Zahlbetrag.*?\\K\\d+,\\d{2}(?=\\s*CHF)', 'gm')
const str = `Zwischentotal 0,00 13,24 906,79 CHF
Zahlbetrag 0,00 13,25 906,80 CHF`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}